[Solved] White Screen of death :( (...it's really not death. Just the flashing mode)

Have you tried disconnecting and reconnecting the display?

Also, what OSes were on the computers?

Wow thanks for the quick reply!

Yes I already tried that :frowning: Strange thing is that it used to work before…

I fully dismantled it and remounted.

(by the way I saw your private message on the forum of the ‘other console’. will reply)

EDIT: Try to remount the display a 3rd time, still the same

1 Like

Windows 10 PRO and a macbook bro (recent model, no idea about exact os version).

1 Like

I’ll be with you in a moment. “Killing” pokitto by program is not possible.

So we just need to reflash you I believe

1 Like

(Sorry for a slightly slower reply this time around, I had to stop to do some DIY.)

It’s ok, you’re allowed to say ‘Arduboy’ here,
@jonne knows there’s a big userbase overlap.

Did you only flash the device on the mac?

The problem with macs are that they insist on dumping hidden .ds_store files everywhere, and it interferes with the Pokitto’s upload mechanism because the .ds_store file gets uploaded to the Pokitto before the firmware.bin, which then prevents the actual firmware.bin from uploading and the Pokitto crashes because the .ds_store file isn’t a valid binary executable.

Someone wrote a script to try to avoid this.

Try reflashing your Pokitto on the windows machine if possible,
or have a go at using the script from the thread I linked to.


Ok, lets go step by step.

That “white screen” means one of two things

  • pokitto is in “flashing” mode
  • there is a broken program in the memory

Pokitto has a small 256kB internal flash memory. That is where the program runs from. If there is a corrupt program in the memory, we need to replace it with a working one.

  1. download start.bin from here [Testing]LOADER & test program for Pokitto
  2. turn off pokitto
  3. connect with USB cable to computer
  4. press AND HOLD the lower back button
  5. while holding back button, turn on pokitto
  6. a drive called CRP DISABLD should appear on your computer
  7. delete firmware.bin from that drive
  8. copy+paste the start.bin you downloaded earlier to CRP DISABLD
  9. let that copy run for the 1-2 secs it takes, then turn off pokitto
  10. turn back on, you should be up and running

IF NOT then report at which step the process failed


You can even say Gamebuino Meta, MAKERPhone, Oroid Go or whatever other things you fancy. There is even a section for discussing those if you want.


Unless you’re on Mac. Like I say, .ds_store files are a pain,
and currently that’s my best guess as to what the problem is…

(If I ever meet the person who introduced them I’ll… do something terrible (I can’t think of anything suitable).)

I must admit, I’ve been contemplating looking into the ZeroPhone.

Is this been fixed?

Please use the pokitto loader for mac. The hidden files mac os uses will lock up the system but if it’s showing a white screen and you plug it in on Mac it shows up as a drive automatically (should not need to hit flash reset buttons) if it won’t show up as a drive I’m assuming there’s another problem going on

1 Like

When it happened to me the pokitto loader for Mac fixed it all I did was load the asteroid game and it was all groovy.

Thank you all for the replies.

First, I never flashed it with a mac. When I first installed my Pokitto I used a Windows PC. So I don’t think I have any .ds_store issue.

@jonne It fails at step 6: Plugging the Pokitto has no effect. I tried to connect it around 50 times, with 3 different PC and 4 different cables. One time it somehow connected (I heard the plug-in sound on my PC) but didn’t worked. Looking in the device manager the USB storage was visible but Windows said something like ‘connection to the device timed out’. Never managed to get that far again…

Small question: When hitting the reset button (top button on back), should I see the Pokitto making a power cycle? i.e. power led turns off-on. Currently pressing the reset button has no effect at all: screen remains white, led remains blue.

Probably one of the Micro USB pins bent.

Micro USB type B is the worst connector invented by mankind. Whoever made it should share the fate of the OSX .ds_store inventor.

PM me your address and I’ll send you a new board.

Edit I have a dozen devices (not pokittos) with a broken Micro B USB


I’ll check. AFAIK you should see some kind of a blink.

Are you 100% sure the back button (the flash mode button) is making contact when you try to connect? If you want to try making a flash connection to the pc without the case, take a bit of aluminium foil (size of your fingertip) and use that to “connect” the back button squiggles on the pcb.

1 Like

Have you tried holding down the lower button instead?

You can put the Pokitto into flash mode by tapping the top button while it is powered on, but you can also put it into flash mode by holding down the lower button while the Pokitto is off and then turning the Pokitto on.

Sometimes it’s a bit difficult to get the button to connect, you have to hold it down quite far and it can be a bit picky about the angle you press the button at.

maybe its time to look at a revision to get a better port so this never happens in the future

Type C perhaps? AFAIK its better in every way.

1 Like

yes, but i think that you need some extra logic to handle the cable compatibility, its meant for usb3.1 and thunderbolt/displayport and stuff, main isue it the variable voltages chargers can have

but its posible

(would personally prefer usb A connector, those are still indestructible)

1 Like

My pokitto came back to life! He is very happy and recovering, see picture bellow :slight_smile:

I think my back buttons were not working that well. I tried a few time, pushing harder, with different angles. I did the procedure of the manual again pushing the buttons harder and with a bit of angle and it worked:

  1. Connect Pokitto with USB cable.
  2. Switch it on.
  3. Press and hold ‘Flash’.
  4. Press ‘Reset’ once.
  5. Release ‘Flash’
  6. Bing, CRP DISABLED appeared :metal:

Small note: When the folder was open there was a single ‘firmware.bin’ file of 0 bytes. So I think the reason of all my troubles was “there is a broken program in the memory”.

Small note 2: I have one loose screw which made the board not firmly stuck on the backplane. This could be the reason why my back buttons aren’t working that well.

Thanks you all for the quick support and replies, it is very appreciated. And sorry for making you loose time on this. :confused:


Don’t worry about it, this is DIY electronics and helping people along.


I think ‘rethink the back buttons’ is steadily creeping up the todo list.
The issue’s gone mostly unnoticed because people haven’t really discussed it until recently.
It’s not a major issue, but it’s inconvenient.

If you hadn’t said you used the Windows computer, I would say that was almost certainly the result of a mac dumping a .ds_store file into the Pokitto.

A few hours of head scratching is better than having to ship a new board.
(It would be a waste to ship a new board if the existing board isn’t actually broken.)

Besides which, that’s what we’re here for (sort of).

(Now you just have to find yourself an interesting game to play. :P)

1 Like