[Testing]LOADER & test program for Pokitto


#1

This binary is intended testing the functions on Pokitto.

It opens “intro44.snd” from the SD card.

You can also test all buttons by pressing them. A box will be drawn in the middle of the screen to show which key has been pressed.

This also contains the SD loader v5 PREINSTALLED!

Binary

start.bin (256 KB)

Sound file to be put on SD card

intro44.snd (1.4 MB)


[Announcement] Pokitto SD card loader v4.0 beta release
Pokitto Gamedisk v07 RELEASED
Learning to talk to Pokitto
Open Pokitto again
Hello from Norway
[Solved] White Screen of death :( (...it's really not death. Just the flashing mode)
Your Pokitto - Show it to the World!
[solved]Crappy sound and loose part
[Solved]Can't get back to loader
#2

Did maxsound.bin load feelgood.bin on SDCard and after that we have the animation + the sound music playing ?

(no sound actually for me just some loud grappy sound)


#3

Arrrgh, wrong file!! Wait!

it is the feelgood.snd file you need to put on the SD disk!


#4

Sound a little grappy and crackling but working (maybe hard to get a clear sound quality with the little hp :wink:
)


#5

i thing at export/convertion a low pass filter could be a nice idea (because of the sample rate limitation).

Very nice to hear Feel Good on Pokitto :wink:


#6

I’m trying to stream sound in my game, but I head nothing. Do I need to do anything different from the simulator?
I have the following in My_settings.h

#define PROJ_HIRES 1
#define PROJ_STARTUPLOGO 0
#define PROJ_GAMEBUINO 0
#define PROJ_GBSOUND 0
#define PROJ_STREAMING_MUSIC 1
#define PROJ_ENABLE_SYNTH 0
#define PROJ_ENABLE_SOUND 1

#7

i maybe don’t have the last version of your game but actually the version i’ve have no sound


#8

No that should be enough.

I will try it out also at some point, maybe I forgot some switch


#9

no source code?


#10

Not yet, be patient Jonne has a lot on his plate :wink:


#11

Sorry, we’re you referring to the Animation or Spinal’s source code?


#12

animation, well it would be just to show how the sound player works


#13

I’m taking a bit of time off. I’ll get to this tomorrow


#14

I don’t know if there’s something wrong with my pokitto, but using the .bin and the .snd from the first post I get no sound :frowning:

[edit] Compiling with the updated lib doesn’t seem to work either.

  • the firmware.bin that initially came on my pokitto does work though.

#15

I had not yet put a new binary. Now it works (at least on 2 pokittos I tried here at home)


#16

If I press the C button and all I get is a black box with the letter C on it.

Also there’s a high pitched noise when the Pokitto boots, the sound playing is ignoring the headphone settings and I’m sure the sound is running faster than it used to.


#17

Ok. Out to lunch. I will take a look


#18

There’s no need to hurry, I’ll be heading off to have dinner in a moment.
(Gotta love those 5 hour time differences.)


In case it’s my fault somehow, or in case any of this is relevant:

My card is 2GB, recently reformatted to FAT32, it contains:

LOA.DER
feelgood.snd
pokitbeasts.pok/map.data
pokitbeasts.pok/overmap.data
pokitbeasts.pok/save.data

All freshly downloaded.

And the file loaded onto the Pokitto itself is the recently uploaded start.bin.

The card is old, but I was able to run Pokitbeasts (which is what I had on before start.bin) and the sound is playing (albeit at a fast pace).


Just to follow up on this:

Seems the C button issue was me pressing C at the wrong time (after the program had started - oops).

I think there’s still some high pitched noise on startup though, and it seems the sound defaults to max volume (though that might be intentional).

I’m not sure if the other sound issues are still true, I’ll double check another day.