[solved]Crappy sound and loose part


#1

I received my Pokitto yesterday and thought the things I tried out just had poor or no sounds but when I tried the Maximum sound demo the sample was barely hearable, I thought there might be something wrong with one of the speaker wires.

After opening up Pokitto gently using a creditcard I found a loose small chip. After Inspecting the mainboard I don’t think it is a free bonus but that it should have been mounted near the audio jack (red square in image). Looking at some of the other surrounding parts I’d say something went wrong with the soldering process.

Not sure what the parts function is and if it’s the cause for the crappy sound as some other parts don’t look mounted well either :disappointed:


#2

Unfortunately that part is one of the two audio opamps (opamp = operational amplifier) through which the sound goes.

I can say honesty that this is the first instance ever of that chip being loose. I’m very sorry for that.

Put me a mail to jonne (at) pokitto.com with your address (so that I do not have to double check user profile vs. the order) and I will send you a new board on monday.

On a bonus note though, I can tell you that other than sound, your board will work 100% if you choose to use it. You can do all the dangerous stuff on it!

Also: if you know how to solder / have a friend who knows soldering ( that part is not hard to solder), you can see it has 3 and 2 legs on opposite sides. You can easily make a fully working spare board if you ever decide to fix it.


#3

I’ve been ninja’d by Jonne, but I’ll post anyway.


A similar thing happened with a USB port recently.
It’s possible they’re from the same batch.

(The solder paste application machine is beginning to get a bit of a reputation.)


(P.S. Hi @Mr.Blinky, fancy running into you here.)


#4

No. That batch is long gone. This is a chance occurrence / maybe received a hard knock while in the mail


#5

Ah, I forgot that post was about a unit from the Kickstarter batch.

In that case, @Mr.Blinky, disregard my musings,
it most likely is just a random occurance.


#6

Well I hope its a one off. But like I said, this is the first time (out of 650 or so) that I see one of the opamps loose. And I personally tested the sound & LCD, put @Mr.Blinky 's Pokitto into the package and loaded with the new loader to boot and still this happened. It just happens I guess.


#7

I have sent the picture to Daniel. He manufactures the boards. Let’s see what he replies.


#8

Thank you!

Cool! Maybe it was ment to be. I always hold back on hacking new and good working stuff. Only like to do reversible experiments. But with crippled/damaged stuff I can go all out.

I hope so too. I don’t know if transport had a role to play in it. There where no dents in the box. but the D-pad had come loose from it’s runner.

Cool to hear your taking personally care of them.

I’ve taken a few more pictures at different angles. looking at the pads where the opamp was and the other opamp, It looks like the solder didn’t flow as well as on the opamps as on the other parts.

Hi @Pharap what a small world it is :slight_smile:


#9

You’re absolutely right.

The opamp looks like its “sitting” on top of the solder.

I think this is a solder reflow fail.

I need to send these pics to Daniel. Thanks alot for the pictures, they really help!

EDIT: and the other opamp is also misaligned!


#10

@Mr.Blinky

Response from Daniel:

I will probe the board through the oven in that position and see that it reached the proper temperature. There may be a cold spot and that will explaing all the trouble I have with the audio.

@Pharap : just FYI, there might have been a problem with the heating elements of the oven: that explains why the opamp in @Mr.Blinky 's board is “sitting on top of the solder” instead of in it

So, confirmed that this is unrelated to the earlier MicroUSB issue.


#11

I received a replacement mainboad from @jonne today. Totally awesome :thumbsup:

My pokitto sounds great now. I didn’t expect the sound to be this loud :smiley:


#12

Hehey! Great stuff! Have fun with the Pokitto.

By the way: we looked at the problem that was on your board. Believe it or not: the problem is that the board had gone through the reflow oven backwards.

The convection of the heated airflow was unable to reach the opamps, because the airflow was blocked by the high audio connector! This is only a problem if the board enters the reflow oven backwards!