White screen of 'death'

I haven’t really used my Pokitto since I first got it almost 2 years ago but thought it was finally time to port over some of my games from other microcontroller based consoles. But first I wanted to try out some of the community games so I put some .bin files on an SD card. The first game flashed fine but the second one go stuck after the progress bar finished filling up.

Now when I switch on my Pokitto I just get a white screen, which from reading various threads sounds like it is stuck because of a bad firmware flash. I’ve tried putting it into flash mode with it connected via USB to my Windows PC and holding down the back bottom button whilst switching on but I don’t get the flash drive appear on my PC.

I’ve tried a different USB cable in case that was the issue but no luck. The only other comment I saw on this thread was that it could possibly be the actual button on the back not connecting so I might try taking my Pokitto apart but is there anything else that I can try first?

The only other thing I would suggest is to try a different computer, usually though, holding the flash button down will force it to detect. Sometimes though, the flash and reset button will not contact perfectly, this might help – Simple Back Button Mod… failing that, perhaps @jonne has some idea what it might be?


As Spinal said, sometimes the back button doesnt workd well, i often have to try a couple time and use the tip of a pen to make sure the contact is made. Once it work, just delete the firmware.bin that is on the drive called crp_disabled and drop a working bin of a game and it should be working again. Its almost impossible to brick a Pokitto. :wink:

Glad to hear back from you here!

@jhhoward and please.start working immediately with FemtoIDE, our own IDE. Its absolutely the best way currently, the situation has improved buckets since you last were here!

1 Like

I’ve already downloaded FemtoIDE and it looks like it will help speed up development once I get my Pokitto up and running again!

I took my unit apart and held a screwdriver over the ‘USB boot’ button pads are to make sure contact was made but it still isn’t showing a flash drive on my PC (I even tried a different PC too just in case)

Any other ideas?

What OS are you on?

Edit : and check with another cable

Edit, ah ok, windows

Taking your Pokitto apart is worth trying.

Unlike certain other consoles the Pokitto is designed to come apart and put back together again relatively easily.
(I say ‘relatively’ because sometimes it can be a bit fiddly.)
I’ve done it at least half a dozen times myself for various different reasons.

I’d recommend prying it open with something stiff but not sharp like a metal ruler, and when putting it back together I find making sure the front is face down makes it easier to keep the buttons in the correct orientation (they have a tendency to come loose if the case is shaken too much when trying to clip it back together).

If the issue is a connectivity issue (which is plausible, the contacts on the back buttons aren’t brilliant) I recommend using my ‘circle of conductive foil’ trick:

I used to sometimes struggle to get the connection,
but since doing the foil trick it works perfectly every time.
(So much so I’m almost tempted to suggest including it as part of the build process. :P)


@jhhoward , lets troubleshoot you step by step

  1. The USB mode can not get broken. It is hardcoded in the ROM silicon of the LPC11U68

  2. Therefore 2 alternative explanations remain

  • the chip does not go into USBISP mode
  • the chip goes into USBISP mode, but the communication to the PC is broken

Now, the easiest thing to do at first is to make double sure you have a working USB cable. Sounds dumb I know but you’d be surprised to know how many faulty cables I have seen. Make sure it is a data cable, not a power only cable. As you are an Arduboy user, I am sure you know this

Next, something more serious. During the Kickstarter, a batch of Pokittos was shipped which had a particularily weak USB connector soldering. Long story. But your next step is to take a look at the USB connector. If it seems suspect (moving) you’re getting a new Rev C board from me, no charge

One easy way to inspect the USB connection is to look at the charging LED next to the power switch. If you connect the Pokitto with power off.to the PC and nothing lights up, either the USB connector of the USB cable is busted

@jhhoward report back when you have looked at these and we will diagnose the next issue

@Pharap’s foil in the rubber button trick worked! I guess I wasn’t making a good enough connection with the screwdriver either when I tried :slight_smile:


The carbon “pill” of the rubber button loses conductivity when dust settles on top of it - likely the cause here.

Good thing you got it working!


Perhaps the screwdriver you tried just wasn’t conductive?

At any rate, glad to know another person has had success with my foil trick,
that means I can confidently keep recommending it when suitable.
(The best part is how cheap it is. It’s a very DIY/Blue Peter solution. :P)