Windows & Linux Simulator repository on github

I might have a clue whats going on

All: please run “gcc --version” and report back. This is mine:

C:\Program Files (x86)\CodeBlocks\MinGW\bin>gcc --version
gcc (tdm-1) 4.9.2
Copyright (C) 2014 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

Possible cause : @krp running Fedora with new GCC 6 while we others (win/ubuntu) have earlier version of gcc

min max has changed in GCC 6:

 This no longer compiles with GCC 6: 
#define max(a, b) (a > b ? a : b) 
#include <stdlib.h> int i = max(0,1); 

The reason is that 'max' is used throughout the standard library, and it's undefined behaviour to define a macro that clashes with any name defined in the standard library. Previously <stdlib.h> was not provided by GCC's C++ std::lib, so didn't #undef min and max. Now GCC provides its own C++-conforming <stdlib.h> and so it does #undef min and #undef max.

I see @Drakker has GCC 6.3.1 while in Fedora … this might be it

Probably is! Got gcc version 5.4 on Xubuntu 16.04 and it works. I’m looking quickly through the package repository on Fedora 25 and the only other gcc version available seems to be 3.4… and when I try to build with it it says there’s no support for stdc++11… and when I try with 98 it doesn’t work. I don’t have time to play with this right now, but I’ll try later tonight if nobody figures it out until then.

When you rebuild the project it also has problem with *.so files and it terminates with error status 1

simulator seems to be broken to many random errors to even list

Is that windows or Linux? Last weekend it was working (windows) but I have not pulled from Github since.

windows, new install of code blocks and everything

I can try it tonight

oh wait looking true it seems to be mingw
wierd since a normal comand prompt helo world seemed to work fine

1 Like

Thanks for the quick updates on the situation @Hanski and @adekto. I am busy with the site backend update at the moment

yea, idk whats going on, these are standard library errors, i tried diferent codeblocks, tried reinstalling mingw
i get diferent errors but there all in stl or mingw library’s

idk if there is a version problem
have checked with codeblocks win32 so its not the compiler itself

1 Like

could you copy-paste at least a bit of the errors / screenshot so I see whats going on?

Latest pull from GitHub works for me: Windows CodeBlocks (v16.01) using Gnu GCC. No errors.

installed codeblocks

no install codeblocks


MinGW version built with wrong exception handling?

i have no idea what you want me to do
its just standard mingw

There are 2 versions of ready-built MinGW that you are able to download: dwarf and sjlj.

You get exactly that kind of errors when you are linking together libraries (dlls) that have been built with incompatible exception handling settings.

Revert back to the minGW you were using when we made the Columns and Coffins thing.

re installed windows…

i do not see any refrence to dwarf or sjlj on mingw downloads, wich one do i use?

Hmm. I can’t find the versions either.

But that message about 'cannot find __gxx_personality" is definitely a compatibility issue and am willing to bet its to do with the exception handling (sjlj) that is a compile-time setting used when MinGW is built

Btw are you trying to build or have you tried clean rebuild also? (.o files are regenerated)

diferent errors
reinstalled everything so idk what to do anymore

thats the error that @krp got when trying to compile with a newer version of gcc

reason is min/max has changed in new gcc. this is not only a pokitto issue

put DISABLEAVRMIN in project build options-> defines to disable min/max defined in pokitto_fakeavr.h

also, which target project are you trying to build?