[Start]1.Assembling and connecting Pokitto to PC


#21

I’ve been trying to record what’s happening with my phone, but it doesn’t seem to happen while I’m recording.
I think it might definitely be a windows file writing issue rather than a pokitto issue. I have to do everything a little slower when holding the phone in one hand and it seems to be working correctly a lot more.
My current theory is either the .bin file is not fully compiled when I copy it, or it’s not fully copied when I reset the pokitto.


#22

…or… the lpcrc.exe (checksum fixer) has not run yet on the binary. This would lead to a non-workable bin


#23

Would it be possible then, for lpcrc.exe to output a different filename rather than replacing the original? Maybe specifically name it firmware.bin just so that people (me) can be 100% sure that the process is complete?


#24

That means recompiling lpcrc from source code… can be done, can’t assign a very high priority right now


#25

That’s fine. Thanks for conquering my stupidity :slight_smile:


#26

No stupid questions here

Here is a similar tool by microbuilder.eu (with source code). I am sure you could mod this very easily to do what you describe.


#27

Do you rename the file firmware.bin and then drag&drop or do you delete the existing file and then copy the replacement over (without renaming)?

I do the latter and haven’t had an issue so far.
I also tend to use ‘eject’ rather than manually pulling the USB cord out or turning the Pokitto off, so maybe that’s also something to do with it?


#28

I can’t do that, I get a ‘not enough space’ error. It might be a windows 10 issue.


#29

Can’t do which?


#30

Can’t copy over the file. Windows doesn’t ask about replacing the file, it just straight out tells me there is no space.


#31

The firmware.bin file created by the boot loader is a map of all of flash. If you check the available space on the disk, you’ll see it’s 0. Your two options are to delete the file first, or copy onto it directly.

It’s interesting that Windows complains there’s no space when you try and overwrite the file. Possibly it’s trying to do something “smart” to keep you from shooting yourself in the foot?


#32

Hrm, I had something similar but I thought it was just because I hadn’t renamed the file to firmware.bin.
In that case my guess is that Windows would normally write the new file first and then delete the old one (to make it easier for someone to cancel the write if it was a mistake).

What about the other things?
Do you use ‘eject’ when removing or do you unplug first, or turn the Pokitto off?

If one of these strategies is less reliable than the others it would be good to identify which so we know what to suggest to people.


#33

For whatever reason, it seems my Pokitto will not register as a flash drive. I’ve tried both the USB connector that came with the Pokitto and the one that came with my Arduboy, and neither works. I also tried using the bare PCB, which still didn’t work.

I’m sure I can still use SD cards, but is there any way I might fix this?


#34

The Pokitto will only show up as a drive after you hit the reset button while holding down the flash button (thought you may be missing this step if you are plugging in the bare PCB?)


#35

jonne said it 3 times in the video, how could someone miss it? :joy:


#36

Easy, by not watching the video :P.
(I readily admit to only skimming it because I found the quickstart guide to be enough.)

Remember though, “there are no stupid questions here”, if @epicdude312 missed that instruction maybe it needs to be clearer? Although he might have followed the instructions and still be getting a problem, we don’t know yet.

Though I will say for the benefit of future readers that it’s also on the quickstart guide:

And a larger version:


#37

I was following the instructions. I don’t know why it wasn’t showing up.

Also, I didn’t plug in the bare PCB; I just opened the case up a little to make sure I was plugging it all the way in…

I’ll try it on my mom’s old PC and see if it’s a problem with the Pokitto or a problem with the computer.
EDIT: Tried it on my mom’s computer and it works fine. Something must be wonky with my PC’s USB ports…

EDIT #2: I’m also using a desktop and my mom’s computer is a laptop…huh…


#38

I thought you probably were, which is why I wanted to avoid jumping to conclusions.

If it doesn’t work on any of the porst then that certainly is odd.

Which OSes do the computers use?

Pre-empting the answer being ‘Windows’:
If you’re on Windows, go into the device manager, click View->Show hidden devices, then look under Portable Devices and see if CRP DISABLD is listed.


#39

Meh, it doesn’t really matter. My mom doesn’t use her old computer anymore, so I set up a little “Pokitto station” with a plug, an SD card reader, a MicroSD adapter, and some MicroSD cards.

I now have the loader working fine, and am running the raytracing program right now :smiley:


#40

If it ever happens with another computer, report it again.

It could be an issue with your computer, but if it’s an issue with the Pokitto it needs to be made known so it can be investigated and fixed or prevented in case it happens to someone else.

As odd as it feels to be saying this, I hope your computer is the one with the problem :P.


At least you’ve got a way of running it I guess.