Sound problems in PokittoLib solved

Hello all

There was a stupid mistake in the sound.Begin function which meant soundInit(); was never called

I have fixed the problem in both PokittoLib in mbed online tools and the git repository.

Remember to have the following in My_settings.h:


Updating PokittoLib in the mbed online compiler

mbed online compiler - update PokittoLib in your project:


I don’t know if this is directly related, but I updated and now I get

C:\Users\Spinal\Documents\GitHub\PokittoLib\Sensitive\PokittoLib\mbed-pokitto\common\retarget.cpp|408|undefined reference to `__wrap_exit’|

I’m not having much luck with all of this.

[edit] I’m using
(which is the updated lib with my direct tile pasted in.

Go to project settings, build options, linker, remove all the -Wl stuff from linker flags

Edit: it all says “wrap”. Its mbed-os stuff.

1 Like

Is playTone working with EmBitz?
I’m quite sure my project should sound something.
At least it work on simulator, but using EmBitz I can’t reproduce anything on hardware.

Setted this My_settings.h


#define PROJ_HIRES 0            //1 = high resolution (220x176) , 0 = low resolution fast mode (110x88)
#define PROJ_ENABLE_SOUND 1     // 0 = all sound functions disabled


Any other hint?

Try with headphones. You might not be using the most up to date pokitto lib, previous versions had a problem with initializing the speaker.


That’s damn true! It’s working in my home stereo!
Thanks @spinal .
I’m quite sure I’m updated with the lib. What it’s happening here, why no sound even at max volume?
I’ll start again with a clean clone.


dumbass me forgot to turn amplifier chip on (in software)


I start again with a clean clone of the repo. But still no luck on sound something without headphones.
I’m using EmBitz and everything should be set up correctly.

Can anybody confirm projects can be build with offline Ide with sound synth enabled?

Can you provide a link to your clone? If not, zip your project and send it to

I admit I have not been cross checking the offline repo since latest changes.

please send me the source file for what you are trying to do and I will see what is wrong

Here a forked repo

Thanks but does not show what you tried to do. Are you trying to use gbsound or streaming from sd or what?

Just now compiled Asterocks from mbed online and sound works.

Going to look at the git repo next

1 Like

didnt have time to test but sound in new merged git repo should work

New repo seems to work. At least I can hear something :grin:

1 Like