Windows & Linux Simulator repository on github

windows, new install of code blocks and everything

I can try it tonight

oh wait looking true it seems to be mingw
wierd since a normal comand prompt helo world seemed to work fine

1 Like

Thanks for the quick updates on the situation @Hanski and @adekto. I am busy with the site backend update at the moment

yea, idk whats going on, these are standard library errors, i tried diferent codeblocks, tried reinstalling mingw
i get diferent errors but there all in stl or mingw library’s

idk if there is a version problem
have checked with codeblocks win32 so its not the compiler itself

1 Like

could you copy-paste at least a bit of the errors / screenshot so I see whats going on?

Latest pull from GitHub works for me: Windows CodeBlocks (v16.01) using Gnu GCC. No errors.

installed codeblocks

no install codeblocks


MinGW version built with wrong exception handling?

i have no idea what you want me to do
its just standard mingw

There are 2 versions of ready-built MinGW that you are able to download: dwarf and sjlj.

You get exactly that kind of errors when you are linking together libraries (dlls) that have been built with incompatible exception handling settings.

Revert back to the minGW you were using when we made the Columns and Coffins thing.

re installed windows…

i do not see any refrence to dwarf or sjlj on mingw downloads, wich one do i use?

Hmm. I can’t find the versions either.

But that message about 'cannot find __gxx_personality" is definitely a compatibility issue and am willing to bet its to do with the exception handling (sjlj) that is a compile-time setting used when MinGW is built

Btw are you trying to build or have you tried clean rebuild also? (.o files are regenerated)

diferent errors
reinstalled everything so idk what to do anymore

thats the error that @krp got when trying to compile with a newer version of gcc

reason is min/max has changed in new gcc. this is not only a pokitto issue

put DISABLEAVRMIN in project build options-> defines to disable min/max defined in pokitto_fakeavr.h

also, which target project are you trying to build?

wel that sorta works i it gave me an error in BmpImage.cpp not knowing what min max was
i added this and that seemed to fix the isue

    #define min(a,b) ((a)<(b)?(a):(b))```

Ok. Who broke the Linux sim? :grimacing:

No just kidding. But yes, the graphics pops up and after a while the program crashes. It used to be rock solid.

Even turning the sound off does not help.

I am going to have to backtrack the history of the repo to see what has happened. Any help is appreciated.

EDIT: it is a sound issue. that is confirmed

I having the same problem too. I hear a small sound clip playing then it crashes. I’m on Ubuntu 16.04 using Code Blocks 13.12


Turn sound off for now from your project settings (PROJ_ENABLE_SOUND 0). I have not been able to locate the source of the problem. CORRECTION: I have not had time to locate the problem in Linux


I got same errors when I was trying Code::Blocks on Fedora 24 !!!