[Solved] Problems with buttons and binaries not running


#1

Hello everyone,

I just got my new pokitto (after it had been held by customs for a week, sigh), I assembled it, and I have a problem getting it to work. But let me start from the beginning.

After assembling, I switched the device on, and saw the pokitto face. For a moment a black rectangle with some sort of indicator appeared in the top left corner, and then just the face, changing randomly. I noticed that the A and B buttons would change the eyes to hearts or closed eyes, and that the down button would stop the mouth from changing randomly, but all other buttons did nothing. I also noticed that the left direction doesn’t even click when I press it, though all the other buttons and directions do.
I looked closely, and I noticed that the speaker is very close to the pins of the connector at the top, so I disassembled the device, put some sticker paper between the speaker and the pins to make sure there is no short, and put it back together again, however, it didn’t change the behavior.

Next, I wanted to try some games, so I found a 2GB sdcard, unpacked the zip file from pokitto_gamedisk_v05.zip on it, inserted it into pokitto and switched it on. There was no change, still the same face changing randomly. I couldn’t find a button labeled “C” on my device, but I pressed all of buttons in turn, and no menu or anything like that appeared. Thinking that maybe the SD card is faulty, I put feelgood.snd on it, and tried again — this time a horrible loud music played in addition to pokitto making faces at me, so I assume it can read the sd card fine.

Next, I connected a USB cable, reset pokitto into flashing mode — a “CRP DISABLD” disk appeared with firmware.bin on it. I copied the firmware.bin as a backup to my disk, deleted it, and copied the crabator.bin on the device. Then I unmounted it, switched off, unplugged, and switched on again — and I got a white screen. I tried with and without the SD card, no difference. I tried a couple of other .bin files, but no difference. I tried to copy the firmware.bin I have backed up initially back onto the device, and still nothing — only white screen.

At this point I really don’t know what else I could try. Any ideas?


#2

Had something similair with the white screen :

animtest.bin worked for me to get it out of the crp_disable mode


#3

C is the bottom button next to the + pad. any other button will dismiss the screen.
When you press C, you should get a black screen then after a bout 1 or 2 seconds, a list of files on the SD card. From there you should be able to load a game.


#4

Well, I tried both the original firmware.bin and just now downloaded and tried the animtest.bin — no change.

My device is not staying in flashing mode, though, as the USB disk is not visible unless I restart it while holding the flash button. It just doesn’t seem to be running the program flashed on it.


#5

I fixed the left button not clicking by de-soldering the switch and re-soldering it better aligned with the pads — the plastic cross was not hitting the button in the center. So at least one issue is gone.
I examined the PCB under a microscope for any shorts. Apart from a few misaligned parts (but still with good connections) and a few balls of solder stuck to the PCB (ouch, seems like they really need to work on their process at the fab) I found nothing suspicious.


#6

You can flash any of the games that come on the sd card zip, they should all have the current loader fully working.


#7

Another data point. When I copy a .bin file to pokitto, unmount it, reset, mount again and copy the file back, it has always the same size of 262144 bytes (as opposed to 261696 of the original .bin file), and there is 1024 zeroes prepended to it.


#8

I think I found why it doesn’t want to run any bin files for me: [Start]1.Assembling and connecting Pokitto to PC

Unfortunately, I don’t have any Windows system available to re-create that original bin file, so I guess there will be no playing with this over the holidays.

I really didn’t expect that a USB MSC would be dependent on the operating system.


#9

I got it to work with:

dd conv=nocreat,notrunc if=xx/pokitto/asterock.bin of=/media/sheep/CRP\ DISABLD/firmware.bin

as hinted at in that application note.


#10

It’s not labelled, it’s the oval-like button on the front, in the middle, at the bottom.
(Not being labelled is intentional.)

There are two ways to put the Pokitto into CRP_DISABLD mode.
That’s one of them.

Again it’s intentional, the Pokitto doesn’t go into CRP_DISABLD just by being plugged in.


Are you on Mac or Linux?

If you’re on Mac, you have the option to use the loader program specially written for Mac (the v2 link seems to be currently broken, though that could just be me):

If you’re on Linux, there’s probably a script somewhere that could do it.


#11

The buttons seems to be all working correctly now too, so I’m a new happy Pokitto user. Thank you all for your help.