[Solved]Pokitto stuck in firmware mode

My power switch broke, so I soldered a couple of pins to it instead and I’m using a jumper to switch it on. At first I thought it was a rousing success but now it’s stuck in firmware mode.

Any ideas?

Never mind, it seems to be working now.

Yeah this happens to me sometimes, likely you had a corrupt binary or you disconnected the Pokitto before the file copied over. I put a solved tag in your title since you figured it out :slight_smile:


How did it break?

It was while I was putting it together after you sent me that replacement board. I think the plastic switch cover wasn’t on properly and kind at an angle, so when I closed the case it snapped off. I was mortified I’d broken the replacement almost immediately after getting it.

The pins and jumper solution works well for now though, so I’m happy.

Soldering a new power switch is pretty easy. Do you want me to send you one?

1 Like

That would be cool, if it’s no trouble. Thanks.

In Windows OS when I remove USB cable before ejecting Pokitto disk same problem appears. Maybe it can solve possible future problems.