[Solved]Pokitto does not appear as a flash drive

I just received my two pokittos and assembled them with my kids. The instructions worked great!

We charged both of them and both of them show the firmware test when powered on. When I connect them to my linux laptop only one of them shows the “CRP DISABLD” flash drive after holding the flash button and resetting or turning on.

I swapped the USB cabled just to exclude this, but those are both good. Also since the reset switch works, I believe the rubber buttons are good.

Any idea what could be wrong? Could it be the USB connections?

Odd… because I have programmed the test bin on both of them, so they have worked

First, eliminate possibility of a bad cable by using another cable

edit: you have done it so forget that

You can check if the problem is the button or the USB connector: if you switch “power on” on the pokitto without connecting usb cable but pressing “flash” button, you should get a white screen. If you do not, the problem is the button. If you do get the white screen, the problem is the USB. Report back and I will help you troubleshoot

1 Like

We do get a white screen, if we hold ‘flash’ and power on the pokitto, without the usb cable connected.

Ok. Button works for sure then.


a nasty question …

do you have a Windows computer somewhere? :blush:

Maybe at work. I have more or less all OS’es available, but Windows.
I just opened the pokitto again and the soldering connection of the USB connector looks great (I took pictures just in case). Also the connector is solid in place and no loose.
What would I need to do on a windows machine?

You could try OSX also. [Start]2.Putting a program on Pokitto, step-by-step

On windows machine, you do not need to do anything but connect the USB cable and press the flash button on reset to get the “CRP_DISABLD”

Why it works better on Windows is that the support for FAT12 is better due to DOS legacy being still built in!

1 Like

The one downside to OSX is that the file manager might try to create a .ds_store file on the SD card.

I’ll try windows tomorrow. For one more datapoint, I’ve tried usbmon under linux (see https://wiki.ubuntu.com/Kernel/Debugging/USB).

When I run

sudo cat /sys/kernel/debug/usb/usbmon/1u

and plug the working pokitto, I get a lot of debug spew. When I plug the one that does not mount, it stays silent.

On the other hand it charges, so the usb connector can’t be totally borked.

5 posts were split to a new topic: White screen when I start the Pokitto

I’ve also tried it under windows 10 today and it does not show up either. I have electronics equipment, anything you want me to check wrt. the usb data lines?

TBH I’m stumped because we never had any issues like this. I haven’t had any that have refused programming yet - and we program them all using the same mechanism

I had the same problem under Windows. I put the Pokkito in USB mode as described, charging via USB worked, too, but the drive did not appear. I tried two PCs and different USB cables.

Then I tried it again two hours later and it worked. No idea what the issue was.

Any progress on this?

Crazy! It is the USB cable. I used a regular one instead of the short white ones and it works. I thought I had swapped them, but apparently not. One of them simply does not work.

1 Like

Good to know. I am moving to higher quality cables now.