Pokitto Start - Setup/Bootloader ect (some photos for waiting)


#21

Do you have a bug tracking system, or do we declare bugs in the forum?


#22

Please make a note in Bugs&Feature requests category here on the forum for now

When I sync the mbed pokittolib / github and pokittosim repos, there will be a unified bug tracking


#23

Here is video about problem. When i press C button in game Chars are starts flashing. It’s not seen in video but up-left corner “c button pressed” sentence appear.

Sorry for bad quality video. First time i’m recording video with this phone :smile:


#24

Ohh when I press C nothing happens :confused: no loader nor bug


#25

had same bug with c button


#26

Yup, I have that also.


#27

i have no clue


#28

I successfully compiled Pokittris in mbed. I loaded its bin from the (squiddy2) bootloader, but then both the game and pressing C for bootloader freeze the Pokitto (after bootloader countdown & volume setting).

[edit] forgot to say that for PokittoHelloWorld.bin the program works but not the bootloader (black screen), also pressing C flashes “Hello world!” in pink (?)


[Game]Pokittris
#29

mbed library can not make a “bootable” bin yet

This is a known limitation, I am working on it at the moment

This is due to the limitations on using a custom scatter file. In the offline IDE there are no problems.

What is happening, is the bin from mbed online compiler writes zeroes over the whole memory space, overwriting the loader. There are several ways to work around the problem, but is not caused by Pokitto - it comes from the mbed platform and the ROM bootloader of the LPC11U68

edit: it seems this limitation has recently been removed from mbed

I will make the mbed compiler fix so that it doesn’t break the loader before monday.


#30

I know what is wrong the binaries were compiled with earlier development libraries. The loader addresses are not correct.

Thanks for that, I will look into it


#31

Can you clarify a little bit how the loader works? does it works similar to gamebuino? is the current game.bin going to contain the boot sequence (saying Press C to…) and then load another loader.bin file from the sd?

I haven’t seen the sd loader menu yet :stuck_out_tongue: because my pokitto does not do anything when I press C.

Anyway, I found an old 512 MB micro sd that I will be using permanently in pokitto and I was thinking on writing a little windows app that retrieves all the compiled files from the forum so you can leave that app in the sd card permanently. Something like “update_all.exe” and it just downloads all the .bin files from the forum.


#32

Update and wiki on loader will come up this weekend.

In short: its not a bootloader, its a loader. It sits as a binary blob at 0x39000.

You can cut&paste it from squiddy2.bin

Better ways coming

Edit: some games dont work atm (arcade and asterocks) and i need time to debug why


#33

@jonne, I’m having another issue. I got my micro SD cards today. I downloaded the game disk, unzipped, placed on card, put card in Pokitto, pushed C, pushed up and it worked. I tested a couple games. Turned it off. Drove to pick up my son and show him. When pushing C I get a blip on the screen that I was able to photograph, then screen is black. I tried reformatting the card but the error persists. I followed the same process for my son’s Pokitto and so far it is working. Here is the photo


#34

flat battery?


#35

I don’t think so. I can still play from the device. Pokittris is on the unit itself. That works with and without the SD card.


#36

Put another binary on it. I think there was some game that was still compiled with the old bootloader and it fails.

BTW: you can’t break Pokitto by programming it. Even if you put total garbage on it, you can always recover


#37

Bingo, that worked! Can I add other games to the SD card that are available on the Games page or will it only work with the games included in the zip file?


#38

Sensitive fails, I know that. I haven’t had time to find out why. Also Micropython supposedly fails also.

In the zip file are games I’ve tested to work. Others you have to try your luck. The problem is I am very tied to shipping all the Pokittos out and haven’t really had time to test as much as I would have wanted.

I am going to improve the SD loader soon, a new version is coming.

Edit: I appreciate all “error reports” and other issues being reported here. They help me to develop the software. So don’t be afraid to give feedback.


#39

I had that, it seems when updating the loader from an offline build, probably using an older pokitto, I get a black screen when the loader starts. I have to use one of the games from the SD card burned to the flash to get the loader back.