Micro USB port came off


#1

As it says in the title the micro USB has worked itself loose. I’ve been doing a lot of dev the last couple of weeks so it’s been in my bag and I’ve been unplugging the USB cable a lot and it worked it’s way loose. It just snapped off altogether.

Any ideas? I pretty much can’t dev at this point can I?


[Solved]White screen when I start the Pokitto
#2

yep. this was a known issue on one small batch of boards: the “feet” of the usb port did not have enough solder.

pm me your name and address, we will ship you a new board asap

btw very sorry about this. 3 cases have been reported


#3

Sorry you had some bad luck man. I’m paranoid about these kinds of things and noticed it takes quite alot of force to unplugged the micro USB cable so I do it very gentle. Half the time I just leave the small cable plugged in and just unplug the full sized USB end. I know my worries could be reality now. I’ll have to be extra careful. Also @jonne what is the empty spot on the board to the right of the USB port for?


#4

Reserved for second USB port in case we release Pokitto Pro with built-in hardware debugger


#5

For everyone wondering what this is about: there was a problem with the solder paste applicator. It made too thin layers in some boards.

We now have improved the paste applicator so that we do not get this problem any more.


#6

Not to make your paranoia worse but I think part of the problem was leaving the micro USB connector plugged in while it was in my bag. I can’t be sure of that though, so take it with a pinch of salt.


#7

For anyone with soldering experience it would be an easy fix if they catch it before the smaller micro USB pins are damaged.


#8

I have the same problem with both Pokittos I ordered. My son used it a handful of times to charge and program. The first board I looked at and saw the lack of solder. Before I could get the second one to compare and add solder, he was using it and now that port is loose (loose but still works)! :disappointed:

So far, he loves it. I got them for him for Christmas and he’s been playing with them since, even sneaking out of bed to play and program. :neutral_face:


#9

I’m sorry for that.

The lack of solder was caused by panel flexing when solder paste was applied. A bunch of boards got through before we noticed the problem.

We now have a solder printer so its no longer an issue.

Send me a PM with your name & address or email to jonne at pokitto dot com for a replacement!


#10

PM sent.

I wasn’t complaining, just explaining. We know this is an open-source, first-run type of project. There’s a learning curve when it comes to things like this–especially with 2 people running the show. :grin:


#11

No problem. There was a real issue causing this problem. We know there were several cases of lack of solder in the USB connector.


#12

I just had this issue myself. I reflowed the solder a but. I don’t know how long it will hold, but for now it seems to have worked.

Out of curiosity, as the Pokitto is aimed at kids, is the not a way to secure the USB port a little better?


#13

I think THT parts are bit more secure than SMD parts


#14

Yep. This issue originated from 2 things:

  1. the reference pad design for the connector as provided by manufacturer was not good. It omitted the additional pads that solder the body of the connector to the pcb. These have been added to the latest rev

  2. solder paste was thin on the board edges as it was applied manually. The panel (=4 boards) flexed under pressure, leaving too much paste in the middle (remember the button shorts we had?) and too little on the edges (=usb connector) resulting in a weak mechanical hold. Daniel now has an expensive paste printer (since December) that eliminates this issue.

These both have been since fixed and we have not had this issue with later builds. Any boards with broken USB have been and will be replaced.


#15

Well, after securing the usb port, I think it might have been damaged when it first came loose. I can’t seem to keep a stable connection, the orange led goes on and off when the cable wiggles. :pensive:


#16

A couple of random ideas:

  • Have you checked there aren’t any accidental shorts or loose connections?
  • Maybe you should try unsoldering it and resoldering it?
  • Or perhaps there’s a way you can test the contact points to make sure they’re doing what they’re supposed to?
  • If you post a few pictures, maybe someone will spot a damaged area?

#17

OK, having looked closely, there were loose connections on the actual pins and one of the pads had came off completely. Probably from the force of plugging in the usb cable when the two side pads weren’t connected. So I carefully removed the usb port and reconnected it nice and straight. I don’t recommend this to anyone who is new to soldering, it is very small and difficult, I had to remove the down button just to be able to get into it.
Anyway, either that missing pad wasn’t needed or there was still enough of it left to complete the connection as it seems that the USB port is working correctly. However, the large pad on the left came off during the process, so it’s only secured on one side.

[edit] Nope, the second time I plugged in the cable, the whole thing came off, ripped all of the solder pads off completely. :frowning:
I assume that there are no other contacts on the board for the USB?


#18

Might be worth investing in these magnetic snap-on / snap-off USB cables (as mentioned on the Arduboy community) for our Pokittos, to avoid putting stress on the surface-mounted connector!


#19

those magsafe like conectors are cool. i wish we could just avoided micro usb all together
usb-c is kinda nice if theres ever a large revision
though i wonder if QI (wireless charging) could be used for programming and charging


#20

I am afraid you will have to ampute a leg if you wont to use a magnetic usb connection. The one i have doenst fit.

Edit : Idea!, could we use the usb port next to it ? Or is it this not possible ?