[Game]Planet Escape [wip]

adventure
game
release

#41

Thanks, I might check that if I have any issues. I’ve been looking forward to Blockitto ever since you first announced your previous version, so it’s exciting you’ll be releasing a playable version soon!

I think I figured out the source of this bug. If you went to the top of the world, it checked for whether you were colliding with any destroyed floating blocks without making sure the blocks were inside the world bounds. This meant jumping at the top of the world boundary caused you to pick up random corrupted blocks with invalid block IDs, When it tried to draw invalid blocks, it would treat various bits of memory as bitmaps, resulting in some pretty crazy visual glitches.

I think I have fixed this, and the patch will be in the next version.

I think I have partially fixed this, but there are still some issues I haven’t dealt with at the top of the world. I also do plan to add a way to get more wood in the future, but there’s no way yet.

Thanks for the feedback on the game!


#42

New version in original post! It features some bug fixes and a new background with parallax scrolling. Many thanks to Vampirics, who provided the background tiles.

Now there is a background for the caves as you travel underground. I’m not sure if it’s distinct enough from the foreground tiles or not, but 16 colors kind of limits the options.


#43

Looking good!


#44

Loaded it up and in the first couple seconds after jumping a little bit it froze.

Rebooted and started again and am NOT disappointed at all. I’m so impressed. This really blows my mind!

I tried to make a house haha… it was difficult because I spawned on a mountain. So lots of travel time! XD got a little sun porch viewing area, windowed to keep slimes out :smiley:


#45

About one in ten times the game freezes within a few seconds after start. I definitely need to fix that. I think it’s something to do with the creatures in the world going out of bounds, but I’m not sure because I can’t get it to happen when I’m in a debugger.

Wow, thanks a lot, I’m really glad you enjoyed it! Thanks for sharing your house too!


#46

If that is so, that means that limiting the world properly should fix a couple of the issues then.

@torbuntu

When shutting off the pokitto and loading the game again… Does it generate a new world for you or you seem to spawn at the same spot over and over?

For some reason, it looks like I spawn at the exact same spot…


#47

Maybe random generator is not initialized correctly in the library?
There was a bug times ago…


#48

Not too sure about that. I think @wuuff told me that it was working properly for him… Anyway that’s why I ask others to check if it’s just on my pokitto.


#49

It seems fixed here:

Can you check on your project version?


#50

@HomineLudens I only used the bin posted in the initial post. I didn’t compiled it.


#51

The three times I played it (including the one crash) it was seemingly a different spot. I’ll play again later and report back my findings :ok_hand:


#52

I found you another bug! I dug to the bottom of the world (I was curious :P) and fell out, then I got that strange glitched tile again. When I hovered over it it printed some random garbage to the screen. The easiest way to fix this would probably be to add a layer of bedrock at the bottom of the world so as to prevent out-of-bounds play.


#53

Thanks, did you find that in the most recent version I uploaded? I tried to reproduce the bug and I can’t get a glitched tile when falling off the bottom of the world. I’ll eventually do something about falling out of the world, either with bedrock like you said or killing the player with a layer of lava.


#54

I deleted the latest bin and re download it a couple time to make sure… And I really spawn at the exact same spot each time. And the world seems to be the same…


#55

Yeah, that was in 0.1.1. I tried building there, do you think that might have something to do with it?


#56

Here’s a video that show what I mean…

Sorry for the sloppy filming but holding the phone and turning on and off the pokitto wasnt exactly easy. :wink:


#57

Not random was a bug that was already killed once. It seems to have reappeared in the mbed online repo.

I will check what is up with that


#58

Had time to find anything? real question would be, did @wuuff compiled the bin using Mbed online?


#59

Yes he did.

Now I remember what the problem is. The time() function is not working properly in mbed online for some reason. That is used to randomize the random seed.

I thought I had that one nailed already. Let me see what I can do.


#60

Hmm, I tried building under the world, too, but I still haven’t been able to reproduce it. Regardless, once I stop the player from being able to fall out of the world, that problem will hopefully go away.

This is a weird bug, because I get a random world every time on my Pokitto, even though I did compile it on mbed. Is there a reason it would work on some Pokittos and not others?