[Game]Celeste classic

game
release
platformer

#1

Celeste

This is a port of Celeste Classic a hardcore platformer by Matt Thorson and Noel Berry from PICO-8.
original work of minirop

Controls:
A to jump, B to dash and C button to save or restart the level.

The latest release:
Celeste.zip (1.7 MB)

Extract to your sd card.

Source code:


#2

Well, it isn’t really playable. But I am pretty excited about it!


#3

can you give more detail please?


#4

The artwork is too grainy to visually see what is going on. I see movement and such but it looks all ripped up and broken.


#5

Hi,

Looks like the graphics aren’t in the right format, so they get a bit jumbled up. Also, the only button that seams to do anything is C, which resets.

Since you don’t have the hardware, you can get a better idea of how it’s going to behave in the emulator:
1


#6

I second this conclusion.

Every other line appears to be missing, so I’m assuming the graphics are intended for a 2bit/4bit mode and the screen is being drawn in a 4bit/2bit mode.


#7

Hey and welcome to the forums!

Could we help you debug the code? We have good experiences of working as a group. The combined firepower of the community usually solves problems pretty fast.


#8

i think i was using the wrong screen mode i changed it to screen mode 15
but now i can’t compile it on mbed online compiler
any one can help with this problem

Error: Identifier “lcdRefreshMixMode” is undefined in “PokittoLib/POKITTO_CORE/PokittoDisplay.cpp”, Line: 300, Col: 4

Code Source
Celeste.zip (34.3 KB)


#9

I’ll take a look


#10

Wow, original Celeste :slight_smile: That is awesome!


#11

@bl_ackrain , Mode15 support added to mbed online compiler

Please right click on “pokittolib” folder in the project tree viewer and choose ‘update’


#12

Yes, i tried also

1


#13

thank you for your quick response
now it compile fine
did you try it on the Pokitto hardware?

Download
Celeste.bin (61.8 KB)


#14

@bl_ackrain , going to check first that the mode15 example works in the mbed online compiler


#15

I tried in the emulator… i will try it on the HW also


#16

On the hardware it runs but the display is a mess.

I need to add something to the online compiler, I’ll be back in a few


#17

it run perfect on the simulator

Untitled


#18

Yes, there is something silly missing. I am working on it. Shouldn’t take long


#19

@bl_ackrain , mode15 test picture did not work, so its a library issue. I will get back to you in a moment


#20

@bl_ackrain , UPDATE pokittolib again, works fully now!!

2

EDIT… controls do not seem to work?