Can't load any games


#1

Hey, I’ve just assembled my Pokitto and tried to upload and play a game.
I followed the instructions and after I reset the Pokitto, the screen is still white and nothing is loading. I tried several games.

Any idea what I should do about it?


#2

I had the same problem at first, but then when I followed the instructions (and understood the procedure) all games from the loader worked fine.
The ”trick” is that you only add one game (.bin) in the first stage. Then you add the rest of the games (multiple bins) to the sd card. Once you reboot the Pokitto the new loader asks if you want to update the loader. Answering yes updates the list and after this you can use the loader to load any game bin on your sd card.
Since this procedure seems to be not that straight forward, I advice that Jonne or someone else upload an istructional video for this.
Here’s a topic that has the setup procedure explained in more detail.


#3

When the screen is white does it still show up in windows ? If yes it is still in CRP_disable mode.


#4

Hey, thank you for your reply.
I am only copying one bin file and it does not work.


#5

Hey, the Pokitto goes out of flash mode and disappears from connected devices.


#6

And when you boot it normally, does the loader appear ? Or does the screen stay white ?


#7

Hi Ciprian!

All Pokittos have been flashed and tested twice before shipping. I am sure we can help you out.

  1. Are you on Windows or Mac?
  2. Have you tried another cable? We just got 1 report of a faulty USB cable

#8

I tried Windows and Mac, 3 different cables. There is no error when copying the bin file.
After I reset the Pokitto, the screen stays white, and no game loads up.

I’ll try to get a hold of an SD card and try it like that.


#9

Did you have something on the screen when you first booted up? There should have been the Pokitto face.

I am wondering if your LCD cable is loose. 95% of errors so far have been that people didn’t lock the lcd cable in place (step 7 in the assembly instructions). So the white backlight goes on, but LCD does not get data.

Also, just to make sure: when you reset after copying the binary, do not press the flash button anymore


#10

Oh yeah, that was it, I messed up step 7. I went back and locked the screen connectors in place and now it works.
Thanks for all your help.


#11

No problem, glad that its working now. I really have to emphasize this more in the instructions!