A non-functioning "right" d-pad button

The “right” button do not work in any of the games. I have measured the button with a multimeter and it works when pressed. So the problem must be the soldering. I tried to re-solder all the four feet, but it did not fix the problem.

Here is the video. The button is the one above the dog.

Maybe I just have to take the button away and clean and resolder it back?
Which of those feet are actually connected? It is hard to see traces.

I’m not much of a hardware person, so this may be a bit of a naive question, but have you tried shorting it with a jumper? Might be a simple way to answer the question of whether or not it’s a button failure…


The problem could be further down the line. Have you looked around the CPU’s legs at all?

Some people who have been here for a while may recall that when I first received by Pokitto the left d-pad button was actually making my Pokitto reset and that the problem was two of the CPU legs being bridged by excess solder. After very carefully scraping the excess off with a sewing needle the board starting working properly.

It’s obviously different circumstances here, but it could be a similar root cause.


Yep. @Pharap is right

1 Like